Software Delivery Repository

Software Delivery Repository   |   Getting Started   |   FAQ  |  Repositories

Mellanox OFED VPI Drivers and Utilities

The "Mellanox OFED VPI Drivers and Utilities" repository provides all packages required for InfiniBand and Ethernet modes of operation with HPE Mellanox adapters on Red Hat Enterprise Linux and SUSE Linux Enterprise Server. Please note that "Ethernet+RoCE" Mellanox Linux drivers are already provided with HPE Service Pack for Proliant. For customers requiring complete InfiniBand functionality, it is recommended to install packages from "Mellanox OFED VPI Drivers and Utilities" repository.

  Browse


Subscribe your system to the MLNX_OFED repository

Red Hat Enterprise Linux

Cut-n-paste the following section (substituting ditribution, architecture and project version) into /etc/yum.repos.d/MLNX_OFED.repo on your system:


[MLNX_OFED]
name=Mellanox OFED VPI Drivers and Utilities
baseurl=http://downloads.linux.hpe.com/SDR/repo/mlnx_ofed/RHEL/dist_ver/arch/project_ver
enabled=1
gpgcheck=0


Where:

   dist_ver      6.7, 7.2, 7.3
   arch          x86_64  
   project_ver   current, 3.4-2.0.0.0 
        

SUSE Linux Enterprise Server

Cut-n-paste the following section (substituting ditribution, architecture and project version) into /etc/zypp/repos.d/MLNX_OFED.repo on your system:


[MLNX_OFED]
name=Mellanox OFED VPI Drivers and Utilities
baseurl=http://downloads.linux.hpe.com/SDR/repo/mlnx_ofed/suse/dist_ver/arch/project_ver
enabled=1
gpgcheck=0


Where:

   dist_ver      SLES12-SP2
   arch          x86_64  
   project_ver   current, 3.4-2.0.0.0 
        


Installing MLNX_OFED packages

Once you are subscribed to the repository, follow instructions from the guides below to install packages from MLNX_OFED Repository:


Using MLNX_OFED repo on RHEL6.2


Using MLNX_OFED repo on RHEL6.3


Using MLNX_OFED repo on RHEL6.5


Using MLNX_OFED repo on RHEL6.6


Using MLNX_OFED repo on RHEL6.7


Using MLNX_OFED repo on RHEL6.8


Using MLNX_OFED repo on RHEL7


Using MLNX_OFED repo on RHEL7.1


Using MLNX_OFED repo on RHEL7.2


Using MLNX_OFED repo on RHEL7.3


Using MLNX_OFED repo on SLES11SP1


Using MLNX_OFED repo on SLES11SP2


Using MLNX_OFED repo on SLES11SP3


Using MLNX_OFED repo on SLES11SP4


Using MLNX_OFED repo on SLES12


Using MLNX_OFED repo on SLES12SP1


Using MLNX_OFED repo on SLES12SP2


Contact